<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:og="//opengraphprotocol.org/schema/" xmlns:fb="//www.facebook.com/2008/fbml"> <!--<![endif]-->
<head>
    <title>Students take action, ask for input as UCF investigates Charles Negy &mdash; KnightNews.com</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://knightnews.com/xmlrpc.php" />
    <script type="text/javascript">var FBAPP_ID ="2866287446784609";window.addEventListener('load', function(){                
				if(window.ga && ga.create) {
					// Hooray! Analytics is present!
                    //alert('Hooray! Analytics is present!')
				} else if(!typeof __gaTracker ==='function'){

(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
 
ga('create', 'UA-9773363-1', 'auto');
ga('send', 'pageview');


				}
			}, false);</script><meta property="og:image" content="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png" /><meta name="author" content="Megan Turner">

	<!-- This site is optimized with the Yoast SEO Premium plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Students take action, ask for input as UCF investigates Charles Negy &mdash; KnightNews.com" />
	<meta property="og:description" content="As UCF investigates associate psychology professor Charles Negy, two students are taking action and asking for the community to weigh in before they meet with the office investigating the professor. Jade Matthies and Alissa Carmi are the individuals behind the Google Form that asks students who have taken a class with Negy to share their [&hellip;]" />
	<meta property="og:url" content="http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/" />
	<meta property="og:site_name" content="KnightNews.com" />
	<meta property="article:publisher" content="https://www.facebook.com/knightnews/" />
	<meta property="article:author" content="https://www.facebook.com/megnturner" />
	<meta property="article:published_time" content="2020-06-10T02:47:37+00:00" />
	<meta property="article:modified_time" content="2020-06-10T03:07:23+00:00" />
	<meta property="og:image" content="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="567" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png" />
	<meta name="twitter:creator" content="@https://twitter.com/megnturner_" />
	<meta name="twitter:site" content="@ucfknightnews" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://knightnews.com/#organization","name":"KnightNews.com","url":"https://knightnews.com/","sameAs":["https://www.facebook.com/knightnews/","https://www.instagram.com/ucfknightnews/","https://twitter.com/ucfknightnews"],"logo":{"@type":"ImageObject","@id":"https://knightnews.com/#logo","inLanguage":"en-US","url":"https://knightnews.com/wp-content/uploads/2020/02/PINwEG0e_400x400.jpg","width":400,"height":400,"caption":"KnightNews.com"},"image":{"@id":"https://knightnews.com/#logo"}},{"@type":"WebSite","@id":"https://knightnews.com/#website","url":"https://knightnews.com/","name":"KnightNews.com","description":"UCF News, Football, and Orlando News - University of Central Florida - Student Newspaper","publisher":{"@id":"https://knightnews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://knightnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#primaryimage","inLanguage":"en-US","url":"https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png","width":1024,"height":567},{"@type":"WebPage","@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#webpage","url":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/","name":"Students take action, ask for input as UCF investigates Charles Negy &mdash; KnightNews.com","isPartOf":{"@id":"https://knightnews.com/#website"},"primaryImageOfPage":{"@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#primaryimage"},"datePublished":"2020-06-10T02:47:37+00:00","dateModified":"2020-06-10T03:07:23+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/"]}]},{"@type":"Article","@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#article","isPartOf":{"@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#webpage"},"author":{"@id":"https://knightnews.com/#/schema/person/792d87861c597d08d031b5a1dc036c71"},"headline":"Students take action, ask for input as UCF investigates Charles Negy","datePublished":"2020-06-10T02:47:37+00:00","dateModified":"2020-06-10T03:07:23+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#webpage"},"publisher":{"@id":"https://knightnews.com/#organization"},"image":{"@id":"http://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/#primaryimage"},"articleSection":"Featured,News","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://knightnews.com/#/schema/person/792d87861c597d08d031b5a1dc036c71","name":"Megan Turner","sameAs":["https://www.facebook.com/megnturner","https://www.instagram.com/megnturner/","https://www.linkedin.com/in/megnturner/","https://twitter.com/https://twitter.com/megnturner_"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KnightNews.com &raquo; Feed" href="https://knightnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KnightNews.com &raquo; Comments Feed" href="https://knightnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KnightNews.com &raquo; Students take action, ask for input as UCF investigates Charles Negy Comments Feed" href="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/knightnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://knightnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='gallery_font_style-css'  href='https://knightnews.com/wp-content/plugins/edge-gallery-premium/css/font-awesome.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='gallery_slick_style-css'  href='https://knightnews.com/wp-content/plugins/edge-gallery-premium/css/slick.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='gallery_slick_theme_style-css'  href='https://knightnews.com/wp-content/plugins/edge-gallery-premium/css/slick-theme.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='gallery_front_style-css'  href='https://knightnews.com/wp-content/plugins/edge-gallery-premium/css/front_style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700&#038;ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://knightnews.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://knightnews.com/wp-content/themes/Newspaper/style.css?ver=7.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://knightnews.com/wp-content/themes/Newspaper/includes/demos/local_news/demo_style.css?ver=7.6' type='text/css' media='all' />
<script type='text/javascript' src='https://knightnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://knightnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://knightnews.com/wp-content/plugins/edge-gallery-premium/js/front_script.js?ver=5.2.3'></script>
<link rel='https://api.w.org/' href='https://knightnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://knightnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://knightnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://knightnews.com/?p=102219' />
<link rel="alternate" type="application/json+oembed" href="https://knightnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknightnews.com%2F2020%2F06%2Fstudents-take-action-ask-for-input-as-ucf-investigates-charles-negy%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://knightnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknightnews.com%2F2020%2F06%2Fstudents-take-action-ask-for-input-as-ucf-investigates-charles-negy%2F&#038;format=xml" />
<meta property="fb:app_id" content="91101496913"/><!-- <meta name="NextGEN" version="3.3.5" /> -->
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://knightnews.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="https:\/\/knightnews.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.6";
var td_get_template_directory_uri="https:\/\/knightnews.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="1";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#ffc904";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-9773363-1', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="https://knightnews.com/wp-content/uploads/2017/04/cropped-kn-512-512-site-top-32x32.png" sizes="32x32" />
<link rel="icon" href="https://knightnews.com/wp-content/uploads/2017/04/cropped-kn-512-512-site-top-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://knightnews.com/wp-content/uploads/2017/04/cropped-kn-512-512-site-top-180x180.png" />
<meta name="msapplication-TileImage" content="https://knightnews.com/wp-content/uploads/2017/04/cropped-kn-512-512-site-top-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta property="og:title" content="Students take action, ask for input as UCF investigates Charles Negy"/><meta property="og:description" content=""/><meta property="og:type" content="article"/><meta property="og:url" content="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/"/><meta property="og:site_name" content="KnightNews.com"/><meta property="og:image" content=""/></head>

<body class="post-template-default single single-post postid-102219 single-format-standard students-take-action-ask-for-input-as-ucf-investigates-charles-negy td-local-news single_template_2 wpb-js-composer js-comp-ver-5.0.1 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/knightnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/ucfknightnews" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/ucfknightnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-87541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-87541"><a href="https://knightnews.com/category/news/ucf-greek-life/">UCF Greek Life</a></li>
<li id="menu-item-87542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87542"><a href="https://knightnews.com/category/sports/">Sports</a></li>
<li id="menu-item-87547" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-87547"><a href="https://knightnews.com/category/news/">News</a></li>
<li id="menu-item-87545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87545"><a href="https://knightnews.com/category/beyonducf/politics/">Politics</a></li>
<li id="menu-item-87546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87546"><a href="https://knightnews.com/category/beyonducf/">Beyond UCF</a></li>
<li id="menu-item-99883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99883"><a href="https://knightnews.com/category/photos_/">Photos</a></li>
<li id="menu-item-99885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99885"><a href="https://knightnews.com/category/life/">Life</a></li>
<li id="menu-item-100907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100907"><a href="https://knightnews.com/category/coronavirus/">Coronavirus</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://knightnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-2">
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/knightnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/ucfknightnews" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/ucfknightnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top-and-bottom-menu" class="top-header-menu"><li id="menu-item-87533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-87533"><a href="https://knightnews.com/">Home</a></li>
<li id="menu-item-87534" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87534"><a href="https://knightnews.com/contact/">Join The Team</a></li>
<li id="menu-item-87536" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87536"><a href="https://knightnews.com/advertising-and-sponsorship/">Advertising &#038; Sponsorship</a></li>
<li id="menu-item-87535" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87535"><a href="https://knightnews.com/about/">About</a></li>
<li id="menu-item-87537" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87537"><a href="https://knightnews.com/contact-us/">Contact</a></li>
</ul></div></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            <a id="register-link">Create an account</a>
                        </div>

                        
                <div id="td-register-div" class="td-login-form-div td-display-none">
                    <div class="td-login-panel-title">Create an account</div>
                    <div class="td-login-panel-descr">Welcome! Register for an account</div>
                    <div class="td_display_err"></div>
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email" value="" required><label>your email</label></div>
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user" value="" required><label>your username</label></div>
                    <input type="button" name="register_button" id="register_button" class="wpb_button btn td-login-button" value="Register">
                    <div class="td-login-info-text">A password will be e-mailed to you.</div>
                </div>

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
                <a class="td-main-logo" href="https://knightnews.com/">
            <img class="td-retina-data" data-retina="http://knightnews.com/wp-content/uploads/2017/02/kni-site-logo-new.png" src="http://knightnews.com/wp-content/uploads/2017/01/kni-site-logo.png" alt=""/>
            <span class="td-visual-hidden">KnightNews.com</span>
        </a>
        </div>
    <div class="menu-header-menu-container"><ul id="menu-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-87541"><a href="https://knightnews.com/category/news/ucf-greek-life/">UCF Greek Life</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-87542"><a href="https://knightnews.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-87547"><a href="https://knightnews.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-87545"><a href="https://knightnews.com/category/beyonducf/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-87546"><a href="https://knightnews.com/category/beyonducf/">Beyond UCF</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-99883"><a href="https://knightnews.com/category/photos_/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-99885"><a href="https://knightnews.com/category/life/">Life</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100907"><a href="https://knightnews.com/category/coronavirus/">Coronavirus</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://knightnews.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  "><div class="td-visible-desktop">

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/side_banner_lower', [300, 250], 'div-gpt-ad-1585805486904-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/top_banner', [980, 127], 'div-gpt-ad-1486343622327-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!-- /140249938/top_banner -->
<div id='div-gpt-ad-1486343622327-0' style='height:127px; width:980px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1486343622327-0'); });
</script>
</div></div>

<div class="td-visible-phone">
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/top_banner_mobile', [320, 50], 'div-gpt-ad-1486346187596-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- /140249938/top_banner_mobile -->
<div id='div-gpt-ad-1486346187596-0' style='height:50px; width:320px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1486346187596-0'); });
</script></div>
</div>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
 
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/2nd_Paragraph_Ad', [[320, 50], [500, 100]], 'div-gpt-ad-1523292018235-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
 
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/3rd_paragraph_ad', [320, 50], 'div-gpt-ad-1569387584942-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
 
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/4th_paragraph_ad', [320, 50], 'div-gpt-ad-1569302298809-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/main_story_glider', [930, 85], 'div-gpt-ad-1568081297452-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/side_banner_upper', [300, 250], 'div-gpt-ad-1500792426809-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1456790284590333');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=1456790284590333&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-102219" class="post-102219 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span class="td-bred-first"><a href="https://knightnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
                               <a title="View all posts in News" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="https://knightnews.com/category/news/">
                                  <span itemprop="name">News</span>    </a>    <meta itemprop="position" content = "1"></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Students take action, ask for input as UCF investigates Charles Negy</span></div></div>

                        <ul class="td-category"><li class="entry-category"><a  href="https://knightnews.com/category/news/">News</a></li></ul>
                        <header class="td-post-title">
                            <h1 class="entry-title">Students take action, ask for input as UCF investigates Charles Negy</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://knightnews.com/author/megan-turner/">Megan Turner</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-09T22:47:37+00:00" >June 9, 2020</time></span>                                                                                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        <div class="td-post-sharing td-post-sharing-top td-with-like"><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/" data-text="Students take action, ask for input as UCF investigates Charles Negy" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>

        <div class="td-post-content">
            <div class="td-post-featured-image"><a href="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png" data-caption=""><img width="696" height="386" class="entry-thumb td-modal-image" src="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-696x386.png" srcset="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-696x385.png 696w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-300x166.png 300w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-768x426.png 768w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png 1024w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-1068x592.png 1068w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-758x420.png 758w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="Screen Shot 2020-06-09 at 9.41.07 PM"/></a></div>
            
<p>As UCF investigates associate psychology professor Charles Negy, two students are taking action and asking for the community to weigh in before they meet with the office investigating the professor. </p>



<p>Jade Matthies and Alissa Carmi are the individuals behind the Google Form that asks students who have taken a class with Negy to share their experiences. Matthies and Carmi said they persisted until the office investigating Negy committed to meeting with them over Zoom on Wednesday.</p><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- /140249938/mid_story_mobile -->
<center>
<small><i>Advertisement</i></small>
<!-- /140249938/2nd_Paragraph_Ad --> 
<div id='div-gpt-ad-1523292018235-0'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1523292018235-0'); });</script></div></center></div>




<p>&#8220;If you have experienced abusive or discriminatory behavior at UCF by Dr. Charles Negy, share your experience and tell your story here,&#8221; the <a rel="noreferrer noopener" aria-label="description of the Google Form reads (opens in a new tab)" href="https://docs.google.com/forms/d/e/1FAIpQLSfEWEzVRR7RgSlgTyYZYlqBuirGCXnQ_-Mx9JfegBAtVzy-Sg/viewform" target="_blank">description of the Google Form reads</a>. &#8220;We are 2 UCF students with a Zoom meeting scheduled with the office investigating Charles Negy and want to make sure your voices + stories are heard.&#8221;</p>



<p>The Google Form can be <a rel="noreferrer noopener" aria-label="accessed here (opens in a new tab)" href="https://docs.google.com/forms/d/e/1FAIpQLSfEWEzVRR7RgSlgTyYZYlqBuirGCXnQ_-Mx9JfegBAtVzy-Sg/viewform" target="_blank">accessed here</a>. </p>



<p>Carmi and Matthies said they have both taken classes with Negy and said they want to ensure all voices are heard. </p>



<p>Carmi, a senior interdisciplinary studies major with areas of concentration in health sciences, and social and behavioral sciences, said she hopes to be a community health worker. The 23-year-old said she wants to work with client populations of diverse cultural and racial communities in order to minimize the current health disparities in our country.&nbsp;</p>



<p>Matthies, who just graduated from the university, earned her degree in interdisciplinary studies with a concentration in communication, and social and behavioral sciences. The 23-year-old said her goal is to work for a nonprofit where she can serve others and fight injustice. </p>



<p>Matthies said students can help by sharing their experiences with Negy using the form — she said both she and Carmi will organize, and communicate all responses during the Zoom meeting on Wednesday.</p>



<p>&#8220;After seeing how many people have been negatively affected by Dr. Charles Negy’s discriminatory and inflammatory behavior in class as well as his hateful and ignorant words, I knew I had to take action for my fellow Knights,&#8221; Matthies said. &#8220;I contacted every department I could reach and persisted until I got a face-to-face [Zoom] meeting.&#8221;</p>



<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-knightnews-com"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="tLDo6MaL5d"><a href="https://knightnews.com/2020/06/ucf-professors-controversial-tweets-claim-black-privilege-exists-in-america/">UCF Professor’s Controversial Tweets Claim Black Privilege Exists in America</a></blockquote><iframe title="&#8220;UCF Professor’s Controversial Tweets Claim Black Privilege Exists in America&#8221; &#8212; KnightNews.com" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://knightnews.com/2020/06/ucf-professors-controversial-tweets-claim-black-privilege-exists-in-america/embed/#?secret=tLDo6MaL5d" data-secret="tLDo6MaL5d" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>



<p>When asked why she is asking students for help, Matthies listed the pillars of the UCF Creed.</p>



<p>&#8220;I believe that our University is at it’s best when we are united as a community that celebrates our diversity and embraces inclusion,&#8221; she said. &#8220;When someone within the UCF family doesn’t embody that, accountability and action must be taken so that all Knights feel safe and welcome on our campus and in our classrooms.&#8221;</p>



<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-knightnews-com"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="3wpH73eLgu"><a href="https://knightnews.com/2020/06/does-the-first-amendment-stop-ucf-from-firing-charles-negy/">Does the First Amendment stop UCF from firing Charles Negy?</a></blockquote><iframe title="&#8220;Does the First Amendment stop UCF from firing Charles Negy?&#8221; &#8212; KnightNews.com" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://knightnews.com/2020/06/does-the-first-amendment-stop-ucf-from-firing-charles-negy/embed/#?secret=3wpH73eLgu" data-secret="3wpH73eLgu" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>



<hr class="wp-block-separator"/>



<p>Last week, UCF said in a news release that no employee may mistreat or discriminate against students in their classes or in any other setting, and no student should fear they will be treated differently because of others’ personal biases.</p>



<p>&#8220;We have been receiving complaints alleging bias and unfair treatment in Dr. Negy’s classroom and have launched an inquiry to gather more information,&#8221; the <a rel="noreferrer noopener" aria-label="statement (opens in a new tab)" href="https://www.ucf.edu/news/addressing-intolerance-in-our-community/" target="_blank">statement</a> reads. </p>



<p>The university encourages members of the community to report concerns to UCF’s IntegrityLine, which also takes anonymous complaints, at&nbsp;<a href="http://www.ucfintegrityline.com/">www.ucfintegrityline.com</a>&nbsp;or 855-877-6049.</p>



<p><em>This is a developing story. Check back for updates. </em></p>
<!-- AI CONTENT END 2 -->
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://knightnews.com/2020/06/3-ucf-football-players-test-positive-for-covid-19/">3 UCF Football Players Test Positive for COVID-19</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://knightnews.com/author/megan-turner/">Megan Turner</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Megan Turner"></span><meta itemprop="datePublished" content="2020-06-09T22:47:37+00:00"><meta itemprop="dateModified" content="2020-06-09T23:07:23-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://knightnews.com/wp-content/uploads/2017/01/kni-site-logo.png"></span><meta itemprop="name" content="KnightNews.com"></span><meta itemprop="headline " content="Students take action, ask for input as UCF investigates Charles Negy"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-e1591755656331.png"><meta itemprop="width" content="1024"><meta itemprop="height" content="567"></span>        </footer>

    
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget widget_text"><div class="block-title"><span>Sponsored Link</span></div>			<div class="textwidget"><center>
<!-- /140249938/side_banner_upper -->
<div id='div-gpt-ad-1500792426809-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1500792426809-0'); });
</script>
</div>
</center></div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Sponsored Link</span></div>			<div class="textwidget"><p><center><br />
<!-- /140249938/side_banner_lower --></p>
<div id='div-gpt-ad-1585805486904-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1585805486904-0'); });
  </script>
</div>
<p></center></p>
</div>
		</aside><div class="td_block_wrap td_block_7 td_block_widget td_uid_2_5ee05808b4aae_rand td-pb-border-top"  data-td-block-uid="td_uid_2_5ee05808b4aae" ><script>var block_td_uid_2_5ee05808b4aae = new tdBlock();
block_td_uid_2_5ee05808b4aae.id = "td_uid_2_5ee05808b4aae";
block_td_uid_2_5ee05808b4aae.atts = '{"limit":"3","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Latest news","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_2_5ee05808b4aae_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_5ee05808b4aae_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5ee05808b4aae.td_column_number = "1";
block_td_uid_2_5ee05808b4aae.block_type = "td_block_7";
block_td_uid_2_5ee05808b4aae.post_count = "3";
block_td_uid_2_5ee05808b4aae.found_posts = "7257";
block_td_uid_2_5ee05808b4aae.header_color = "#";
block_td_uid_2_5ee05808b4aae.ajax_pagination_infinite_stop = "";
block_td_uid_2_5ee05808b4aae.max_num_pages = "2419";
tdBlocksArray.push(block_td_uid_2_5ee05808b4aae);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>Latest news</span></h4></div><div id=td_uid_2_5ee05808b4aae class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/" rel="bookmark" title="Students take action, ask for input as UCF investigates Charles Negy"><img width="100" height="70" class="entry-thumb" src="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-100x70.png" srcset="https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-100x70.png 100w, https://knightnews.com/wp-content/uploads/2020/06/Screen-Shot-2020-06-09-at-9.41.07-PM-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Students take action, ask for input as UCF investigates Charles Negy"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://knightnews.com/2020/06/students-take-action-ask-for-input-as-ucf-investigates-charles-negy/" rel="bookmark" title="Students take action, ask for input as UCF investigates Charles Negy">Students take action, ask for input as UCF investigates Charles Negy</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-09T22:47:37+00:00" >June 9, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://knightnews.com/2020/06/3-ucf-football-players-test-positive-for-covid-19/" rel="bookmark" title="3 UCF Football Players Test Positive for COVID-19"><img width="100" height="70" class="entry-thumb" src="https://knightnews.com/wp-content/uploads/2020/05/stadium_1-100x70.jpg" srcset="https://knightnews.com/wp-content/uploads/2020/05/stadium_1-100x70.jpg 100w, https://knightnews.com/wp-content/uploads/2020/05/stadium_1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="3 UCF Football Players Test Positive for COVID-19"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://knightnews.com/2020/06/3-ucf-football-players-test-positive-for-covid-19/" rel="bookmark" title="3 UCF Football Players Test Positive for COVID-19">3 UCF Football Players Test Positive for COVID-19</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-09T15:53:09+00:00" >June 9, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://knightnews.com/2020/06/ucf-refuses-to-accept-profits-from-white-shaming-book-professor-says-he-will-donate-to-charity/" rel="bookmark" title="UCF refuses to accept profits from &#8216;White Shaming&#8217; book, professor says he will donate to charity"><img width="100" height="70" class="entry-thumb" src="https://knightnews.com/wp-content/uploads/2020/06/Copy-of-Twitter-Post-Untitled-Design-100x70.png" srcset="https://knightnews.com/wp-content/uploads/2020/06/Copy-of-Twitter-Post-Untitled-Design-100x70.png 100w, https://knightnews.com/wp-content/uploads/2020/06/Copy-of-Twitter-Post-Untitled-Design-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="UCF refuses to accept profits from &#8216;White Shaming&#8217; book, professor says he will donate to charity"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://knightnews.com/2020/06/ucf-refuses-to-accept-profits-from-white-shaming-book-professor-says-he-will-donate-to-charity/" rel="bookmark" title="UCF refuses to accept profits from &#8216;White Shaming&#8217; book, professor says he will donate to charity">UCF refuses to accept profits from &#8216;White Shaming&#8217; book, professor says...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-07T19:24:35+00:00" >June 7, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="widget widget_text"><div class="block-title"><span>Twitter</span></div>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/UCFKnightNews" data-widget-id="247416030266269696">Tweets by @UCFKnightNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside><div class="td_block_wrap td_block_social_counter td_block_widget td_uid_3_5ee05808b88cf_rand td-pb-border-top"><h4 class="block-title"><span>Follow us</span></h4><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">48,883</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/KnightNews">Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_instagram"><div class="td-social-box"><div class="td-sp td-sp-instagram"></div><span class="td_social_info">4,416</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="http://instagram.com/UCFKnightNews#">Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">21,844</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/UCFKnightNews">Follow</a></span></div></div></div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><!--
<div id="amznCharityBanner" style="position: relative">
 <div><a href="http://smile.amazon.com/ch/27-2214236"><img src="https://d1ev1rt26nhnwq.cloudfront.net/ccmtblv2.png" id="banner" style="border-style: none;"></a></div>
 <table style="position: absolute; text-align: center; width: 300px; top: 97px; height: 65px; vertical-align: middle"><tbody><tr><td style="vertical-align: middle">
     <div style="max-height: 54px; overflow: hidden; padding-left: 10px; padding-right: 10px;">
       <span style="font-family: Arial; font-size: 26px; line-height: 26px;" class="charityNameSpan">KnightNews.com</span></div></td></tr></tbody></table></div>
-->
<!-- Place this tag where you want the badge to render -->
<g:plus href="https://plus.google.com/112787810759865852820" size="smallbadge"></g:plus></div>
		</aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><script>(function() {
  var _fbq = window._fbq || (window._fbq = []);
  if (!_fbq.loaded) {
    var fbds = document.createElement('script');
    fbds.async = true;
    fbds.src = '//connect.facebook.net/en_US/fbds.js';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(fbds, s);
    _fbq.loaded = true;
  }
  _fbq.push(['addPixelId', '442196219260794']);
})();
window._fbq = window._fbq || [];
window._fbq.push(['track', 'PixelInitialized', {}]);
</script>
<noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=442196219260794&amp;ev=PixelInitialized" /></noscript></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script src="//platform.twitter.com/oct.js" type="text/javascript"></script>
<script type="text/javascript">twttr.conversion.trackPid('l6b9c', { tw_sale_amount: 0, tw_order_quantity: 0 });</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=l6b9c&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
<img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=l6b9c&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
</noscript>
</div>
		</aside>            </div>

            <div class="td-pb-span4">
                            </div>
        </div>
    </div>
<div class="td-footer-bottom-full">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://knightnews.com/"><img class="td-retina-data" src="http://knightnews.com/wp-content/uploads/2017/02/kni-site-logo-new.png" data-retina="http://knightnews.com/wp-content/uploads/2017/02/kni-site-logo-new.png" alt="UCF News from KnightNews.com Student Newspaper" title="UCF newspaper coverage"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>KnightNews.com is the leader in UCF News -- standing for students. UCF news and information by students, for students, a UCF student newspaper, 100% independent of the University of Central Florida.<div class="footer-email-wrap">Contact us: <a href="mailto:news@knightnews.com">news@knightnews.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/knightnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/ucfknightnews" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/ucfknightnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-and-bottom-menu-container"><ul id="menu-top-and-bottom-menu-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-87533"><a href="https://knightnews.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87534"><a href="https://knightnews.com/contact/">Join The Team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87536"><a href="https://knightnews.com/advertising-and-sponsorship/">Advertising &#038; Sponsorship</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87535"><a href="https://knightnews.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-87537"><a href="https://knightnews.com/contact-us/">Contact</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Copyright KnightNews.com All Rights Reserved | Independent UCF Newspaper                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://knightnews.com/wp-content/plugins/edge-gallery-premium/js/slick.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://knightnews.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.6'></script>
<script type='text/javascript' src='https://knightnews.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://knightnews.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.6 (rara)
        Deploy mode: deploy
        
        uid: 5ee05808b98e1
    -->

    <div class="td-container"><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/140249938/top_banner', [980, 127], 'div-gpt-ad-1486343622327-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script></div><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=91101496913&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://knightnews.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://knightnews.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced (SSL caching disabled) 

Page cache debug info:
Engine:             disk: enhanced
Cache key:          
Creation Time:      1591760904.000s
Header info:
X-Powered-By:       PHP/7.0.33
Content-Type:       text/html; charset=UTF-8
X-Pingback:         https://knightnews.com/xmlrpc.php
Link:               <https://knightnews.com/wp-json/>; rel="https://api.w.org/"
Link:               <https://knightnews.com/?p=102219>; rel=shortlink


Served from: knightnews.com @ 2020-06-09 23:48:24 by W3 Total Cache
-->